博客终于升级到WordPress 3.X版本

时间: 2011-05-28 / 分类: 个人心情 / 浏览次数: 23,223 / 112个评论 发表评论

终于,Louis Han 把本博客从 WordPress 2.9.2 一跃升级为 WordPress 3.1.3 版本了。这是本博客发展史上一次跨越性的升级,一次有着重要意义和深远影响的升级,此次升级标志着本博客的发展跨上了一个新台阶,翻开了崭新的一页!

自从 WordPress 3.x 系列版本问世到现在已经过了整整一个年头了。在这一年里,Louis Han 一直畏首畏尾,不敢跨出那一步,捅破那层窗户纸。可是我知道我不能再等下去了,看 Chrome 和 Firefox 的发展轨迹,再等下去 WordPress 4.X、5.X 版本都要酝酿出炉了。

升级之前最大的担心有两块:一个是怕主题兼容性有问题,另一个是博客用了不少的插件,生怕插件也会有兼容性问题。但是时隔一年,我深刻的认识到以前的想法是多么的不成熟,一年过去了,像我一样使用 WPINK 主题的朋友肯定已经升级了,也没有遇到问题,一年的时间,只要是还在更新的插件,肯定也已经兼容新版本了。于是,在备份了数据和博客程序之后,果断自动升级。然后,成功了!

打开多个浏览器分别测试了一下,在IE8、IE9、Firefox 4、Safari 5、Opera 11、Chrome 11一众浏览器中表现良好,Louis Han 感到相当满意。至于IE6?鉴于 WordPress 官方都已经宣布弃之如敝履了,那就让它继续杯具去吧!

截图集:http://min.us/mvkp8PW

历史上的今天

2017年:理想与道德——评易中天《王安石变法》(10条评论)

2015年:病来如山倒(88条评论)

2014年:GJB7691-2012数字示波器检定规程(31条评论)

2013年:Thinkpad X230预装Win8降级到Win7(69条评论)

2010年:如何保存整个页面用于离线阅读[译文136](54条评论)

2009年:《藏地密码》7 端午纪念精编版,PDF电子书…(0条评论)

2009年:《粉红豹2(Pink Panther 2)》(2条评论)

2009年:《藏地密码》7 香巴拉之夜 第五部分 正面交锋(下)(0条评论)

2009年:《藏地密码》7 香巴拉之夜 第五部分 正面交锋(上)(0条评论)

2008年:Windows 7,还是别等了(0条评论)

2008年:ASP.NET:ListBox数据合并问题(0条评论)

2006年:一日行踪(0条评论)

2006年:看看我的UC在线时长吧^_^(2条评论)

2006年:今天是什么好日子?(0条评论)

2006年:可悲,为了看到闾丘露薇的文章,不得不注册凤凰博客(0条评论)

112个评论

  1. 小灰
    2011/05/29 18:29:20

    貌似我每次都跟进挺快的。。。

  2. hostgator
    2011/05/29 20:04:08

    的确WP放弃IE6了,的确WIN也让大家放弃IE6,但是中国用户使用IE6的还是很多的,占了一多半哦!你可以放弃这么多的人吗?

  3. MK
    2011/05/30 00:12:15

    我还停留在2.9+

  4. 晴枫
    2011/05/30 09:36:17

    除了登陆后顶上多了一条工具条,加了个自定义菜单,其他使用上没太大变化

  5. iseeyou
    2011/05/30 11:10:13

    我一直都是第一时间升级…

  6. 番茄
    2011/05/30 14:43:03

    只要有新版本我就更新。

  7. 番茄
    2011/05/30 14:51:11

    你是使用的什么主题?

  8. Seaice
    2011/05/30 21:33:42

    我是一直更新的,IE8 和 IE9 可以共存?貌似我也全都安装了这些浏览器的……不过用的最多的是 Chrome, 但是默认的还是 IE…

  9. 漠北
    2011/05/30 22:22:00

    从接触wp开始就是从3.1开始的好像,现在反正也就是跟着官方的升级脚步,看到后台有提示就跟着升级了,好像也没发现什么问题

  10. 山野愚人居
    2011/05/31 07:50:51

    第一段话说的好拉风啊

  11. baros博客
    2011/05/31 08:54:26

    哈哈,我用IE6,帮你测试下哦。。

  12. 软件街小秘
    2011/05/31 19:53:55

    我也是3X版本了…………

  13. 云在天边
    2011/05/31 20:04:18

    wordpress后台编辑器tinymce好像一直没更新(V3.2.22 ?),在IE9下无法编辑,囧

  14. 自在
    2011/05/31 20:08:17

    基于某些原因,我还不打算升级到3.1.3~哈

    • Louis Han
      2011/06/10 14:25:02

      @自在, 等下一个版本吗 ?

      • 自在
        2011/06/10 23:50:01

        @Louis Han, 不是,因为之前修改过主程序,老了记忆又不好,忘了修改的部分~哈,不过最后还是升级了

        • Louis Han
          2011/06/10 23:51:23

          @自在, 升级是早晚的事情,修改源文件的时候应该单独保留一份

  15. 浩子
    2011/05/31 20:14:16

    我才升级到3.1.2
    不久官方就又更新了

  16. aisinvon
    2011/05/31 20:41:30

    官方只要一放出升级包,我就会更新

  17. 严重浪漫
    2011/05/31 20:42:37

    俺当时也是一狠心升级了的,结果啥事也没有。
    其实,只要备份好数据库、网站文件,可以大胆的升级。

  18. Jacse
    2011/05/31 23:02:10

    每个版本出来,都是直接升级的。

    • Louis Han
      2011/06/10 14:19:37

      @Jacse, 嗯,我也是直接升级,不过中间隔的时间长了点

  19. 子猴
    2011/06/02 07:33:31

    嗯 是应该早升级罗,我的是只要出来一个新版本就会升,一直保持着同步

  20. lifishake
    2011/06/02 12:18:05

    我也觉得如非必要,就不必升版本.
    但是一年前一不小心点错了…

  21. Dianso
    2011/06/02 21:52:45

    你终于跟上潮流了。。。。。。。。。

  22. MF
    2011/06/02 23:23:03

    IE8和9可以共存啊?

    • Louis Han
      2011/06/10 21:31:33

      @MF, 其实不能共存,我用IE8截图之后,升级到了IE9 🙂

  23. 明戈
    2011/06/06 09:04:22

    升级好啊 升级了.. 安全了 是这么回事么?

  24. 爱惜
    2011/06/06 23:49:26

    我的还没升级。我怕跨版本升级会出问题。

    • Louis Han
      2011/06/10 22:24:23

      @爱惜, 保存好数据库和原来的博客数据,出了问题好恢复

  25. 严重浪漫
    2011/06/08 11:41:23

    WP的频繁更新很让人烦!

  26. 娄娄
    2011/06/09 13:07:58

    博客的模板挺不错的··不知道你的插件应用多不多啊?会不会影响速度?

评论分页: 1 2

发表评论

您的昵称 *

您的邮箱 *

您的网站